» » Ошибка «Провайдер контента уже авторизован» в Google Play

Ошибка «Провайдер контента уже авторизован» в Google Play

При попытке установить бета-версию официального клиента ВКонтакте 4.0 для Android многие пользователи столкнулись с проблемой: приложение не устанавливается, а смартфон выдает сообщение: «Провайдер контента уже авторизован». Аналогичные сложности возникают и у тех, кто устанавливает приложения Telegram и Активный Гражданин. Поиск причин столь необычной ошибки привел к следующим результатам: оказывается, недавно сервисы Google Play обновились до версии 8.3.0, и обрели нового провайдера — AppMeasurementContentProvider. Теперь при одновременном обращении двух приложений к этому провайдеру возникает данная ошибка. Приложение, установленное первым, работает нормально, а второе установиться не может, и на экране возникает вышеупомянутое сообщение. Что делать? Удалять первое? Но для начала нужно хотя бы выяснить, какая программа из установленных на Android-устройстве уже использует провайдер, и только потом удалять ее, освобождая его для более предпочтительного софта.

Ошибка «Провайдер контента уже авторизован» в Google PlayОшибка «Провайдер контента уже авторизован» в Google Play

Чтобы выявить приложение, «оккупировавшее» AppMeasurementContentProvider, нужно установить любую программу, собирающую логи Android — например, CatLog. После этого необходимо включить запись логов и попытаться установить из Google Play нужное приложение. Как только появится сообщение об ошибке "Провайдер контента уже авторизован", нужно открыть приложение CatLog и сохранить логи. Открывать сохраненные логи ("catlog/saved_logs") можно в любом блокноте, предоставляющем возможность поиска. В строку поиска по логам вводим следующее сочетание:
com.google.android.gms.measurement.google_measurement_service
Когда требуемая строка будет найдена, в конце предложения вы увидите имя того самого приложения, которое заняло провайдер и мешает установке. Останется только решить, которое из приложений для вас важнее — уже установленное или новое. В последнем случае найденное приложение придется удалить, а установку выбранного повторить.

P.S. Есть информация, что в Telegram 3.4.2 данный баг уже ликвидирован, и можно попытаться установить это приложение заново, но уже после установки бета-версии официального клиента ВКонтакте. Кстати, служба технической поддержки этой социальной сети уже в курсе возникшей проблемы. Так что, есть все шансы на быстрое исправление ситуации.
Источник: http://fan-android.com/

3 комментария

  1. Droidify 17 января 2016 22:21
    Данная проблема может, также, проявляется, как ошибка 505. Решение находится здесь.
  2. владимир 7 февраля 2016 10:43
    Ошибка при получении данных с сервера
  3. aigul 7 февраля 2016 18:16
    Не могу войти плей маркет
Войти:
Имя: *
E-mail:
© 2013 — 2016 Fan-Android.com